ffmpeg-static

by eugeneware

GitHub Readme.md

ffmpeg-static

ffmpeg static binaries for Mac OSX and Linux and Windows.

Supports macOS (64-bit), Linux (32 and 64-bit, armhf, arm64) and Windows (32 and 64-bit). The ffmpeg version currently used is 4.3.1.

Note: The version of ffmpeg-static follows SemVer. When releasing new versions, we do not consider breaking changes in ffmpeg itself, but only the JS interface (see below). To stop ffmpeg-static from breaking your code by getting updated, lock the version down or use a lockfile.

npm version build status minimum Node.js version

Installation

This module is installed via npm:

$ npm install ffmpeg-static

Note: During installation, it will download the appropriate ffmpeg binary from the b4.3.1 GitHub release. Use and distribution of the binary releases of FFmpeg are covered by their respective license.

Electron & other cross-platform packaging tools

Because ffmpeg-static will download a binary specific to the OS/platform, you need to purge node_modules before (re-)packaging your app for a different OS/platform (read more in #35).

Example Usage

Returns the path of a statically linked ffmpeg binary on the local filesystem.

var pathToFfmpeg = require('ffmpeg-static');
console.log(pathToFfmpeg);
/Users/j/playground/node_modules/ffmpeg-static/ffmpeg

Check the example script for a more thorough example.

Sources of the binaries

The build script downloads binaries from these locations:

The build script extracts build information and (when possible) the license file from the downloaded package or the distribution server. Please consult the individual build's project site for exact source versions, which you can locate based on the version information included in the README file.

Show your support

This npm package includes statically linked binaries that are produced by the following individuals. Please consider supporting and donating to them who have been providing quality binary builds for many years:

Building the project

The unzip, tar CLI executables need to be installed. On macOS, use brew install gnu-tar xz.